DigiCert Individual Identity Proofing services may be unavailable
Incident Report for Imprivata
Resolved
Thank you for your patience, we have confirmed this identity proofing issue has been resolved.
Posted Aug 18, 2023 - 16:24 EDT
Monitoring
Our ID proofing partner has applied a fix and customers are confirming that it is now working again. We will continue to monitor the situation closely but are confident that the issue is resolved.
Posted Aug 18, 2023 - 15:22 EDT
Update
Our development team continues to work alongside our partners to address this high-priority issue.

We have identified all providers that started the proofing process this week and failed to complete it. Those individuals should receive an email from admin@digicert.com with a link allowing them to complete the process through a standard web browser.

In the meantime, providers can continue to use Passport, Permanent residence card or Military ID without issue.

We continue to focus our efforts on resolving this critical issue ASAP.
Posted Aug 18, 2023 - 14:55 EDT
Update
The issue has been isolated whereby some users are unable to ID Proof when selecting 'Drivers License' as the primary form of identification verification. As a workaround, if available, self ID proofing can continue instead with use of Passport, Permanent residence card or Military ID without issue.

If any of those additional forms of identification are unavailable and an end user started ID proofing via the Drivers License path please contact Imprivata Support with the name and email of the provider where we will provide a direct link to DigiCert to continue the proofing operation.

We continue to work with DigiCert on full remediation.
Posted Aug 17, 2023 - 19:09 EDT
Update
DigiCert Identity Proofing may continue to be affected as fixes are implemented. Imprivata and our partners are currently working to restore functionality.
Posted Aug 17, 2023 - 10:22 EDT
Identified
The issue has been identified by our partner and a fix is being implemented.
Posted Aug 16, 2023 - 18:35 EDT
Investigating
Imprivata has been made aware that DigiCert Individual Identity Proofing services may be down for some users. DigiCert and Imprivata are investigating the issue and we will update this page as we learn more.
Posted Aug 16, 2023 - 18:05 EDT
This incident affected: Imprivata Confirm ID (EPCS – DigiCert Individual Identity Proofing, Informational Notices).