Imprivata Confirm ID Cloud Service Performance Degradation 10/25/20
Incident Report for Imprivata
Resolved
This is to confirm that services remain operational since remediation steps had been taken as of 1:12am EDT. This incident is now being marked as closed.

We apologize for any inconvenience or disruption this may have caused.
Posted Oct 25, 2020 - 01:37 EDT
Monitoring
Imprivata has identified one of our server nodes got into a bad state. Remediation steps have been taken to restore full functionality to this server and all services tied to it. We will continue to monitor the situation closely for further occurrences.
Posted Oct 25, 2020 - 01:22 EDT
Investigating
As of 12:04am EDT Imprivata has been made aware of degraded performance currently impacting our Cloud Token Service that can affect Confirm ID Authentications, Push Tokens, Validations, and more. We are still investigating, but will be updating as soon as we have new information to provide.
Posted Oct 25, 2020 - 01:02 EDT
This incident affected: Imprivata Confirm ID (Remote Access – RADIUS and Legacy, Remote Access – Cloud-Based, EPCS – Authentication with Imprivata ID, Clinical Workflows – Authentication with Imprivata ID, Third Party SMS, Informational Notices).