Production GroundControl incident
Incident Report for Imprivata
Postmortem

On Saturday, 2 December 2023 around 7:45pm ET, GroundControl experienced an increase in traffic that caused the database performance to gradually degrade until it became overwhelmed. The slow database performance caused a lot of connections to fail and retry, manifesting as a large traffic spike. Steps were taken to both increase capacity and reduce traffic, after which GroundControl began to function. Service was restored at 9:20pm ET.

Posted Dec 07, 2023 - 08:43 EST

Resolved
Imprivata has resolved the cloud incident affecting GroundControl. All systems are now functional. We will have a brief incident summary published here in 1-2 business days.
Posted Dec 02, 2023 - 21:36 EST
Monitoring
Imprivata has worked to restore full GroundControl functionality. We continue to monitor to ensure no further impact.
Posted Dec 02, 2023 - 21:19 EST
Identified
Imprivata has identified the issue affecting checkout for GroundControl. Work has been done to restore functionality and expect things to be working now. Another update will be sent soon.
Posted Dec 02, 2023 - 21:03 EST
Investigating
Imprivata is aware of an ongoing product-impacting GroundControl incident. Device checkout is currently affected. Teams are aware and working to resolve the issue. We will update here with further updates as they're available.
Posted Dec 02, 2023 - 20:41 EST
This incident affected: Imprivata GroundControl (US Shared Cluster).