GroundControl Deployments Delayed or Failing
Incident Report for Imprivata
Postmortem

At 09:28 AM EST, The Imprivata Dev Ops teams received multiple reports that Checked Out Phones were stuck in deployment queues. Technical teams engaged and determined this was caused by a service interruption at an external email vendor, which affected GroundControl. At 10:47 AM EST, Imprivata began a staggered restart of the instances to remediate the issue and operations began to normalize. Imprivata is actively working towards mitigations to permanently remediate future occurrences of this issue.

Posted Feb 06, 2024 - 16:43 EST

Resolved
This issue has been resolved.
Posted Feb 02, 2024 - 11:34 EST
Monitoring
All services have been restored and normal operations have resumed. We are monitoring the situation closely.
Posted Feb 02, 2024 - 11:08 EST
Identified
We have identified an issue with a third-party email service impacting deployment performance. Imprivata is working with the vendor to resolve the issue.
Posted Feb 02, 2024 - 10:17 EST
Investigating
Multiple reports of delayed and failing deployments on the US-shared cluster. The team is investigating.
Posted Feb 02, 2024 - 09:44 EST
This incident affected: Imprivata GroundControl (US Shared Cluster).