Mobile Access Management services unavailable for some customers

Incident Report for Imprivata

Postmortem

On May 19, 2026, some MAM server customers experienced degraded performance and intermittent workflow failures. The primary impact occurred between approximately 2:30 PM and 2:54 PM Eastern Time. Our investigation indicates that unexpected database activity caused inefficient query execution and degraded performance. Service recovered after the database condition cleared and queued work drained. We are implementing additional safeguards and monitoring to detect long-running transactions, database cleanup inefficiency, and connection-pressure conditions earlier.

Posted May 26, 2026 - 15:52 EDT

Resolved

Mobile Access Managment services continue to operate normally. This incident will now be resolved.

Expect RCA to be posted here in the coming days.
Posted May 19, 2026 - 15:18 EDT

Monitoring

Services have been restored, and the situation has stabilized. If you had reports of issues, please verify that service has been restored. If you continue to experience any issues, please contact Customer Support - https://www.imprivata.com/contact-us.

We will continue to monitor the situation closely.
Posted May 19, 2026 - 15:00 EDT

Investigating

We are seeing service delivery failures for some Mobile Access Managment customers. Our team is engaged and investigating as a priority 1 incident. More updates to follow
Posted May 19, 2026 - 14:49 EDT
This incident affected: Mobile Access Management (US Cloud Services).